You are hereServer

Server


Finding ib_logfile0, ib_logfile1 and ibdata1 on MAMP

ib_logfile0
ib_logfile1
ibdata1

You will need this files, probably to delete them on MAMP/MAMP PRO when changing your "innodb_log_file_size" in my.cnf
Right location is very hard to find it is /Library/Application Support/appsolute/MAMP PRO/db/mysql

Git setup with hook for post-receive.

I have setup a simple git workflow.

In one directory on server I made bare repositroy

$ mkdir git-dir && cd git-dir
$ git init --bare

and in other one a folder for my live site

$ mkdir /var/www/www.example.com

then in the git-dir folder edit the post-receive hook

$ vi hooks/post-receive

and add this to file

#!/bin/sh
GIT_WORK_TREE=/var/www/www.example.org git checkout -f

after that, make this file excutable

$ chmod +x hooks/post-receive

Checking my.cnf settings that are not set

On my WAMP, or MAMP or normal server you may wonder what are the settings for your MySQL that are not set in my.cnf file. There are lot of them and to get quick look at defaults all you need is to run query (you can run it in phpmyadmin for example)

show variables;

and you will have all the variables and their values shown.

Drush

If you are running into this error while using drush

Directory ..../drush/cache/default exists, but is not writable. [error] Please check directory permissions.

Run this to solve it

sudo drush version
sudo chown -R $USER ~/.drush

MAMP - Drush, can't connect to Database

Using drush on local machine is great. If you have problems where drush can't connect to DB of your drupal, It is probably because of the problem with PHP path so either try something like this

https://github.com/drush-ops/drush#additional-configurations-for-mamp

which advise you to put your PHP path into PATH
export PATH="/Applications/MAMP/Library/bin:/Applications/MAMP/bin/php5.3.28/bin:$PATH"

and/or use this export DRUSH_PHP=/Applications/MAMP/bin/php/php5.3.14/bin/php to add variable to make your drush run.
Seems the first one is the one that does the trick here.

p.s.

MAMP MySQL server doesn't start

If your mysql server won't start in MAMP you should run

sudo killall -9 mysqld

and this will probably make it run again.

WSOD or white screen of death and error reporting

Sometimes you will have a WSOD and nothing to show for. One simple solution to get what is a problem is to insert the following lines into the Drupal's index.php, that should set PHP to report all errors.

<?php
error_reporting(E_ALL);
ini_set('display_errors', TRUE);
ini_set('display_startup_errors', TRUE);
?>

and you will probably see that some module is making a problem, so you can fix it or disable it.

Curl on Localhost and WAMP on x64

I was going nuts over how to install CURL on 64 bit windows. I need it for some module and just enabling it from Wamp panel didn't work. So I searched for solutions and there are quite a few combos and solutions offered online but the only thing that worked for me and what was needed is

Navigate to WAMP\bin\php(your version of php)
edit php.ini
Search for curl, uncomment extension=php_curl.dll
Navigate to WAMP\bin\Apache(your version of apache)\bin\
edit php.ini
Search for curl, uncomment extension=php_curl.dll

Drupal Drush Command Cheat Sheet Copy

Everbody likes Drush, why wouldn't you. Anyway I copied cheat sheet from some PDF as this is a drupal dump site and this way I can find it quicker and make also some additions to it.

When available, there is a shorter version of the same command in parentheses.

cache clear (cc) Clear all caches.

cron Run all cron hooks.

disable (dis) Disable one or more modules.

download (dl) Download core Drupal and projects like CCK, Zen, etc.

enable (en) Enable one or more modules.

PM-UPDATE needs the following modules installed/enabled to run: update

Recently I Installed Drush to windows http://drush.ws/drush_windows_installer, scared that it won't work like it should I tried to update some site so I go to local site directory and try pm-update. I get this message

pm-update needs the following modules installed/enabled to run: update. [error]
The drush command 'pm-update' could not be executed.